First time here? Check out the FAQ!
x

"unhandled firewire bus reset or a firewire error. (22)" then "No error. (0)"

0 votes
44 views

hi Kyma community.

I'm using MultifileDiskPlayer on the timeline to trigger samples from disk in a set sequence..(!Trigger nextIndexMod:..). It's been working fine in other instances - so there is nothing wrong with the code or the sound. But in two cases when I try and load certain samples (all mono 24 bit 44.1) it gives me the following message - both on the sound itself and when I try to compile the timeline.

"unhandled firewire bus reset or a firewire error. (22)" then "No error. (0)"

..and it doesn't play...

I've tried various changes - the only one that works is changing the samples. but I've checked the samples themselves and they are fine.

Any ideas how to fix this?

thanks!

Yannis

p. s I'm not even using firewire!

asked Sep 28 in Using Kyma by yannisky (150 points)
"I've tried various changes - the only one that works is changing the samples. but I've checked the samples themselves and they are fine."
What is different between the samples that work and the samples that do not work (in terms of numbers of channels, bit-resolution, total size (duration), wav vs aiff) or any other differences that turn out to be a clue? If you do fewer than 78 samples, does it make a difference?
Hi
Thanks for the quick response. I can get it to work if I reduce the amount of samples in the folder to something like <40. But then it also starts corrupting the samples with others in the timeline - or older samples. It’s strange because another multi disk player in the timeline has also 70+samples and it works fine.

Having said that I did manage to find a work-around for the project - which is to use the RAM multisample player (the total samples are only 10mb in this case) and this functions fine. But I’d still like to understand why the disk option in this case doesn’t work - maybe it’s a bug?
..and to answer your previous question - all the samples are the same for all the cases - which work and don’t: mono 24 bit 44.1 WAV - mostly 0.5-2 sec.

Please log in or register to answer this question.

...