First time here? Check out the FAQ!
x

"anticpation" on midi note out

0 votes
76 views
hello everybody,

so I did this basic sequencer with 3 STGC

the first STGC generates a value called !Count that I also use as a "step pointer" for my sequencer, generated by: (!Run bpm: !BPM) nextIndexMod: 16 reset: !Reset

the second STGC generates the trigs, with: !Count of: #(!sw01 !sw02 !sw03 !sw04 !sw05 !sw06 !SW07 !sw08 !sw09 !sw10 !sw11 !sw12 !sw13 !sw14 !sw15 !sw16

thethird STGC generates the "notes", with !Count of: #(!note1 !note2 !note3 !note4 !note5 !note6 !note7 !note8 !note9 !note10 !note11 !note12 !note13 !note14 !note15 !note16)

if I use an oscillator within Kyma, everything works fine.

but if I send MIDIOutputEvent a strange thing happens. The Trigs works properly, while there is an anticipation on the notes! so !note16 send the pitch for !sw01, !sw01 send the pitch for !sw02 and so on.

I would like to understand what is happening and whether I didi some mistake.

thanks a lot.

peace.

d
asked Oct 7, 2016 in Capytalk & Smalltalk by domenico-cipriani (Adept) (1,240 points)

2 Answers

0 votes
 
Best answer
Thanks for uploading the sound.

 

You have the MidiOutputEvent sound feeding in to a mixer with the Input Channel 5. Try removing the Input Channel 5 sound and removing the "MIDI + audio input" mixer so the MidiOutputEvent is feeding straight into the same mixer as all your STGCs.

If that works for you, this is my rationalisation of how I think kyma works (someone correct me if I've got this wrong!)

I think of the signal flow diagram more as an "execution flow" diagram. Processing of the Sounds starts on the left and goes to the right. Everything that's feeding into the same mixer will be executed during the same sample cycle. So I imagine what's going on in your sound is that the Event values in your MIDIOutputEvent are updating a cycle after they are being set in the STGCs... this might account for how it's getting out of sync.
answered Oct 14, 2016 by alan-jackson (Master) (3,770 points)
selected Oct 14, 2016 by domenico-cipriani
thanks Alan, now it is working!
that was really helpful to make me understand the "execution flow".
peace.
d
0 votes

Dear Domenico,

to align one !HotValue to another you can use the Capytalk message alignWith:

  Delays the rcvr trigger to align with the argument trigger !KeyDown alignWith: (1 bpm: !BPM)

delays incoming !KeyDown to align with next beat

In your case you would allignWith: the pitch of the note with your triggers.

I hope that helps!

Best,

Chris

answered Oct 7, 2016 by christian-schloesser (Adept) (2,030 points)
thanks Chris.
it helps to solve the problem, but I would like to understand why it happens.
Can you upload your sound?
Dear Domenico, i can only guess what your mistake was. If you upload your sound we all can have a closer look and maybe someone has some tips & tricks. One of the best things in Kyma is that there are many different ways to come to a specific result. When i started 7 years ago with Kyma i was often "building" my sounds in a total different way then today.  Best Chris
here we go,
it´s just the very basic version of it.

https://www.sendspace.com/file/8u1l35

the problem is only with the midi. if I use this sequencer to trig a kyma oscillator, it works fine.
best
d
...