Home Forums Tips & Techniques KymaConnect 2 BETA Support

Viewing 15 posts - 16 through 30 (of 54 total)
  • Author
    Posts
  • #1845
    Scott Miller
    Participant

    also, tried (literally) new ethernet cable; no joy.

    #1846
    Delora Software
    Participant

    Correct, directly connecting USB controller to *either Pacarana USB port does not show the device or register receipt of MIDI data.

    OK, that is something you need to pursue with Symbolic Sound. KymaConnect has no influence over the Pacarana’s USB MIDI system.

    Running a dedicated wifi network direct from Pacarana to connect iPad/Kyma Control *does work as it should, so Ethernet port on Pacarana works.

    What version of macOS are you running?

    Some thing to check/try:

    1. Does Kyma 7+ work as expected when you direct connect the Mac and Paca via Ethernet?
    2. Is the Mac’s Ethernet port set to DHCP, or are you using a fixed IP address? Also, from macOS’s Network preference pane select “Advanced”, then the TCP/IP tab, and report how IPv6 is set up.
    3. What IP address does the Mac show when the Ethernet cable is plugged into the Paca, and the Paca is powered. What IP address does the Paca report?
    4. Try connecting with the Mac’s Wi-Fi turned off. If it shows the same yellow/offline pattern as before let it keep trying for at least a minute.
    5. Can the Mac connect to the same Wi-Fi network that you set up for the Paca and iPad? If so connect the Mac to the Wi-Fi without any Ethernet connection to the Paca. Run Kyma 7+ and verify that it works with that configuration.
    6. If #5 succeeds try running KymaConnect while Kyma 7+ is running.
    7. If the Wi-Fi access point you are using to create the Paca’s Wi-Fi network has multiple ports (like a switch or hub) try connecting the Mac to it.

    Finally, I want to confirm that you are not using a FireWire connection between the Mac and Paca, and that KymaConnect never shows red for its status LED at the bottom.

    #1847
    Scott Miller
    Participant

    What version of macOS are you running?

    10.15.4

    Some thing to check/try:

    Does Kyma 7+ work as expected when you direct connect the Mac and Paca via Ethernet?

    Yes.

    Is the Mac’s Ethernet port set to DHCP, or are you using a fixed IP address? Also, from macOS’s Network preference pane select “Advanced”, then the TCP/IP tab, and report how IPv6 is set up.

    DHCP, Self assigned, IPv6 Off.

    What IP address does the Mac show when the Ethernet cable is plugged into the Paca, and the Paca is powered. What IP address does the Paca report?

    169.254.136.137 (Mac) 169.254.134.149 (Pacarana)

    Try connecting with the Mac’s Wi-Fi turned off. If it shows the same yellow/offline pattern as before let it keep trying for at least a minute.

    Did not solve.

    Can the Mac connect to the same Wi-Fi network that you set up for the Paca and iPad?

    It can. As you may know, Kyma 7+ won’t launch if it has a network connection but no access to the Internet.

    If so connect the Mac to the Wi-Fi without any Ethernet connection to the Paca. Run Kyma 7+ and verify that it works with that configuration.

    Does not work.

    If #5 succeeds try running KymaConnect while Kyma 7+ is running.

    If the Wi-Fi access point you are using to create the Paca’s Wi-Fi network has multiple ports (like a switch or hub) try connecting the Mac to it.

    N/A

    Finally, I want to confirm that you are not using a FireWire connection between the Mac and Paca, and that KymaConnect never shows red for its status LED at the bottom.

    No FireWire. No Red lights.

    #1848
    Delora Software
    Participant

    I need to digest your latest info, but in the mean time:

    Set the Mac’s Ethernet port, IPv6 to “Link-local only”. Be sure and click “Apply” after you exit to the main Network preference pane, before you close the Network preference pane.

    Power off the Pacarana (if powered) and connect the Pacarana’s Expansion B port to the Mac’s Ethernet adaptor. Now, perform the follow steps:

    1. Stop KymaConnect if it is running.
    2. Turn the Mac’s Wi-Fi off.
    3. Power up the Pacarana; wait a minute.
    4. Run KymaConnect; wait a minute. Did it connect?
    5. Leave the Pacarana powered up, and KymaConnect running. Take a screen shot  of KymaConnect’s status screen.
    6. Stop KymaConnect.
    7. Take a screen shot of KymaConnect while it is showing the “General” tab
    8. Take a screen shot of KymaConnect while it is showing the “Pacarana” tab
    9. Take a screen shot of the main Network preference pane while the Ethernet port is selected, and the Paca is still connected and powered.
    10. Email the screen shots to our main support email address.

    One other question, you stated this about your Ethernet port settings:

    DHCP, Self assigned, IPv6 Off.

    How did you turn IPv6 off?

    #1849
    Scott Miller
    Participant

    Power off the Pacarana (if powered) and connect the Pacarana’s Expansion B port to the Mac’s Ethernet adaptor. Now, perform the follow steps:

    1. Stop KymaConnect if it is running.
    2. Turn the Mac’s Wi-Fi off.
    3. Power up the Pacarana; wait a minute.
    4. Run KymaConnect; wait a minute. Did it connect?

    YES

    1. Leave the Pacarana powered up, and KymaConnect running. Take a screen shot  of KymaConnect’s status screen.
    2. Stop KymaConnect.
    3. Take a screen shot of KymaConnect while it is showing the “General” tab
    4. Take a screen shot of KymaConnect while it is showing the “Pacarana” tab
    5. Take a screen shot of the main Network preference pane while the Ethernet port is selected, and the Paca is still connected and powered.
    6. Email the screen shots to our main support email address.

    WILL DO

    One other question, you stated this about your Ethernet port settings:

    DHCP, Self assigned, IPv6 Off.

    How did you turn IPv6 off?

    I DO NOT HAVE AN ANSWER. I’M SURE IT’S TO DO WITH MY WORK USING MY COMPUTER AS A UNITY3D SERVER WITH OSC COMMUNICATION BETWEEN KYMA AND UNITY.

    #1850
    Scott Miller
    Participant

    Logged in this morning and was confronted with the Caps Lock responses of my last post–seemed like a good way to distinguish answers in the thread yesterday but in the light of day, yikes, looks like a lot of yelling; sorry for that! And thank you for the speedy replies and troubleshooting!!

    #1851
    Delora Software
    Participant

    I took it as intended. Nested quoting is not a feature of this forum, at least that I have been able to discover. So I am not sure what else you could have done. I tried using italics once and I got an HTML mess. Thanks though for letting me know.

    #1855
    Delora Software
    Participant

    I want to summarize the results of the previous posts between Scott and myself regarding the issue that was preventing a successful connection. This was due to a bug that I was able to reproduce. The bug was triggered when the Mac’s Ethernet port was set up with IPv6 disabled. This is not something that most users would encounter because the only way to do that on macOS 10.14+ is by executing commands from Terminal. So this was a good find and Scott’s help bringing this to my attention is greatly appreciated.

    I have uploaded a new version of the KymaConnect 2 BETA, BETA 3 (build 200.3) to Kyma 7 Community Library. This release addresses the above bug and other related issues.

    #1856
    Knut Kaulke
    Participant

    Hello everybody,

    I would also like to offer my help to test the new Kyma 2 in a Wormhole setup consisting of 2 Pacaranas.
    Currently I’m working in a set with KymaConnect 1 under macOS 10.14.6, which Doug was very helpful in setting up 🙂 The two Pacaranas are connected via ports A (A->A) and B (B->B) using Cat6 cables. I also connected my Mac Mini to the Ethernet input of one of the Pacaranas using another Cat cable. This Pacarana also has the audio interface and is also connected to the Mac Mini via Firewire.

     

    #1857
    Delora Software
    Participant

    Thanks for the offer Knut!

    The difficulty with using a multi-Pacarana Wormhole, and a Pacarana-to-Mac direct connection, is due to a network routing limitation. This was not specific to KymaConnect. I would expect KymaConnect 2 to work in the same set up that KymaConnect 1 worked. So, at least in theory, you should be able to upgrade from KymaConnect 1 to the most recent KymaConnect 2 BETA (Beta 3). Leave the cabling the same, and keep “PacaDHCP” enabled. However, there may be an opportunity to use KymaConnect 2 to without the PacaDHCP work-around. This should also be tested, which could be accomplished by just disabling PacaDHCP.

    Here is my suggestion:

    1. Uninstall KymaConnect 1. Hopefully you still have the latest installer (1.0.2) in case you need, or want, to revert to using KymaConnect 1. If you do not then contact me at our support email.

    2. Download and install the latest KymaConnect 2 Beta. Leave the rest of your set up the same, including keep PacaDHCP running. Try to use this set up and report back here.

    3. If step #2 is successful then try disabling PacaDHCP. Also change the Mac’s Ethernet port IP4 setting from the manual value to DHCP. Reboot the Mac mini and power cycle the Pacarana. Run KymaConnect 2 and see if it is able to connect. If it does then that means that PacaDHCP is no longer necessary with KymaConnect 2.

     

    #1858
    Knut Kaulke
    Participant

    Thank you very much for the description.
    I have just installed Kyma Connect 2 and observed the following in my Wormhole set:
    If you follow step 2, there is a connection from and to the Pacarana but Kyma Connected is on yellow. (See screen shot)

    If I follow step 3, then no connection is set up at all.

    Attachments:
    You must be logged in to view attached files.
    #1860
    Delora Software
    Participant

    Based on your test it looks like PacaDHCP is still necessary. You should try to use the configuration from step #2 and see if it works as expected. The connection seems to be working fine based on your screenshot. I believe that the bottom status LED showing yellow is incorrect, probably a bug. I will try to reproduce it. Try disabling Ext1 and see if that causes the bottom status LED to show green.

    #1861
    Delora Software
    Participant

    Knut, there is one more thing that I would like you to verify in your network configuration. Open up System Preferences: Network, select the network port you use to connect to the Pacarana, and then click on the “Advanced…” button. Select the TCP/IP table and check how “Configure IPv6” is set. If it does not say “Automatically” or “Link-local only” let me know, and retry #3 after you have set it to either of those two values.

    #1862
    Delora Software
    Participant

    I can confirm that the bottom status LED is showing yellow due to a minor bug. It is incorrectly interpreting a Ext MIDI slot with either the input or output set to “not connected” as an error.

    Out of curiosity, why are you creating an IAC port to receive MIDI from the Pacarana? Are you using KymaConnect’s routing and filtering to modify the MIDI stream?

    #1863
    Knut Kaulke
    Participant

    IPv6 was actually set to “off”. I have now set it to “automatic” and repeated step 3. Only this time I also disabled my Ext. in and outs in KymaConnect.
    It works KymaConnect is fully connected according to the status display:)

Viewing 15 posts - 16 through 30 (of 54 total)
  • You must be logged in to reply to this topic.