First time here? Check out the FAQ!
x

Suddenly cant initialize audio interface

0 votes
209 views
hi there,

After a long Kyma break, I was in sonic bliss for the last couple of days. Then all of a sudden, this afternoon, I run my setup like usual, and Kyma wont load. I get Firewire host disconnected error after Pacarana cant initialize the audio interface. I am using TC Konnekt 24D. There was no win update overnight, no tampering with hardware, after yesterdays session I literally closed Kyma, shut down Pacarana and turned off the computer. And now today, however I try to run the setup, the blue FW status light on Konnekt just keeps blinking until Pacarana reports Firewire Host Disconnected.

At first I though that Konnekt went bust, but I rewire it solo, enable the driver in Windows, and as a regular soundcard it works like a charm.

The way I use the setup is :

Konnekt FW to PC

Konnekt FW to Pacarana

I dont have a separate audio interface for other work, I enable and disable the TC driver before and after my Kyma session. I have Win 10-64 bit, all the latest drivers/updates and a fresh Kyma 7 reinstall.

ex nihilo!
asked Feb 24 in Using Kyma by bolelojsgmail-com (160 points)
Have you tried connecting as: PC --> Pacarana FW and Pacarana FW2-->TC?

Alternatively, have you tried connecting PC Ethernet --> Pacarana Exp Port B and Pacarana FW-->TC?
Thanks for the swift comment. I have tried all your suggestions, including others from the Installation guidelines on the website and I get the same error. I cant wrap my head around this, why the sudden change ?? Im getting paranoid that maybe the previous blissful days were just a delusion....
I have some new information. If I setup audio on the Pacarana Setup menu, and choose Konnekt24 there by hand, the devices get connected, which is confirmed by the steady FW status light on the Konnekt. But as soon as I run Kyma and it loads me to the main screen, and Pacarana starts searching for an audio device, then the FW light starts blinking again, and Pacarana reports FireWire Host Disconnected. Is this perhaps some Windows thing ??

I just reinstalled both Konnekt sofware and Kyma and the same thing is happening.
Even more info : I managed to get into Kyma, with the Konnekt turned off and only the Pacarana running. I noticed that even though it is connected to a turned off Konnekt (which is in turn connected to PC) the Pacarana reports that the Fire Wire host is connected. So I get into Kyma, and turn on the Konnekt and the same second Pacarana reports FireWire Host Disconnected, and Kyma throws the following error : Unhandled FireWire Bus reset or a FireWire error (22)
Could you please contact us by email so we can try some more detailed tests with you? Thanks!

1 Answer

0 votes
Have you tried the Firewire legacy driver for windows? That is the only way my system works properly. Sometimes windows update disconnects the previous driver and puts in a new one.
answered Feb 26 by gregorycichoracki (200 points)
gregory thanks a lot for the answer. Do you suggest a specific driver version? Or should I just search for FW legacy driver Windows 10 ?
I use 1394_OHCI_LegacyDriver.msi , think I got it on Microsoft website
Thanks so much gregory. But still, no effect. In the last two days, I cant even get to Kyma to make a debug log....
...